Everything is back to normal and you can now creating collections and mint NFTs
Posted Oct 15, 2022 - 03:25 UTC
Update
We've noticed improvements in our Creating Collections and Minting NFTs. The team is still monitoring this to know when it's fully resolved
Posted Oct 14, 2022 - 22:42 UTC
Update
We have noticed this is a larger issue with the Polygon blockchain as we're seeing high gas fees and network congestion. We will monitor and update this page once anything changes. We’re really sorry to be holding you up today!
Posted Oct 14, 2022 - 21:16 UTC
Identified
We've identified that the issue is caused by one of the third-party solutions we use to implement the collections and NFT minting. Be rest assured the team is working on minimising the impact it has on our core features.
Posted Oct 14, 2022 - 20:02 UTC
Investigating
We are experiencing degraded performance when creating collections and minting NFTs. It seems tied to an issue we've seen before and our engineers are still investigating. Will update as soon as we know more.