Performance Degradation: Creating NFT Collections
Incident Report for Tellie
Resolved
Both issues, creating Collections and creating individual NFTs, have been fixed and the Tellie Creator experience is back to full functionality.
Posted Jul 05, 2022 - 21:03 UTC
Update
In verifying our fix of the NFT Collection creation issue, we identified a second issue regarding creating NFTs within the collection. We have identified the cause of the second issue and are actively working on a fix.
Posted Jul 05, 2022 - 18:20 UTC
Identified
Creators are currently unable to create new NFT Collections. We are aware of the issue and actively addressing it.

We're really sorry to be holding you up today!
Posted Jul 05, 2022 - 15:43 UTC
This incident affected: Page Designer.